List Manager Forum

Problems with the date field / filter options / bulk update

User vlistomatic 2016-07-18 14:45:31


I'm just playing around with the LM component and I faced 3 problems. Great component, but i do need a little bit of help with the fine-tuning.

Date issue
One of my entry fields is the date (list field settings type: date). The date is saved in the right format (dd-mm-yy); however, in the front-end view the date field is always displayed as the current date instead of the date I entered.

filter options
The country example on the demo page shows above the table a filter field with the following options: show filters, apply filters and disable filters. I do get the filter field above my table, however; the only option I see is "disable filter". I want the same filter field as in the country example but I'm kinda stuck.

Bulk update
I enabeld the bulk update function in the ACL and I do get a bulk update button; however, I don't have the option to select specific rows.

I hope somebody can help with the above issues.

Edited by vlistomatic - 18.07.2016 14:45

Moonsoft support 2016-07-21 07:39:19

we suggest to check that you've set the two date formats (database and front-end), with the one you need. We'd also need to know if this happens if you introduce new records from front, back end, or loading csv, all of them? We'll try to reproduce here.

In order to add filters to your table, you must enable them for the needed columns at the fields configuration. For each field you will find a setting called 'autofilter' that you can enable to add filter options to your toolbar. You can choose there if you will want a filter typed text, combo, range...

Regarding selection, the checkboxes may be hidden because any restriction you've set to your permissions. Please check you've at your module/component configuration the setting 'Allow changes'=YES, and you've restricted the options that will be visible using the acl for each joomla group.

Please let us know if you need further help with this.


User vlistomatic 2016-07-21 17:28:08


Thanks for the help. I managed to get the right settings for the autofilter and the bulk setting issues. The date issue is still remaining: No matter how I upload the data (frontend, backend or via CSV import) the date is always displayed as the current date instead of the entered date, However; everything looks fine in the "manage data" section in the backend.

I use the following date format (configuration):
database date format: dd-mm-yy
date format: dd-mm-yy

I also found out that it isn't possible to select the autofilter option "range" in the view dialog settings (only "select", "text" and "checkbox multiple" can be selected). The option "range" can only be selected in the list fields settings. As soon as I want to display selected and sorted data via the view settings I loose this functionality in the autofilter.

Edited by vlistomatic - 21.07.2016 17:28

Edited by vlistomatic - 21.07.2016 17:32

Moonsoft support 2016-07-21 23:12:43


About date issue, please check that 'Database date format' match all records on your list.
Sorry, in case of range, by now this option is only in list but not in view. We'll add this feature in next release (planned to launch before September).


User vlistomatic 2016-07-22 10:02:19


All problems solved! Some of date fields contained a leading zero and other didn't so in fact my dataset contained a mix of dd-mm-yy and d-m-yy. Thanks for the good support and good to hear that extra functionality will be added with the next update.

Support/development 40 hours

With the peace of mind of having a professional team at your service (20% discount)

Buy now!

Create dynamic calculators

Buy now!